Partial Service Disruption Across Select Regions

Incident Report for Veza

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 13:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 25, 2026 - 10:56 UTC

Investigating

We are investigating partial service disruption across select regions(eu-central-1, eu-west-2, ca-central-1).

We appreciate your understanding and patience and we will share an update once we have more information.
Posted Feb 25, 2026 - 09:45 UTC